This support article explains the cause of this error and how to identify/resolve the issue. You may have come across the following error when previewing your courses;

Cause of Error 

This error appears when the asset that has been referenced in a Display Condition has been removed from your course.

After asset has been deleted

Resolution  

  • In order to resolve the issue you will need to identify which Display Condition is missing the asset ID in the Select field. Please note: if the deleted asset was used in more than one Display Condition there may be multiple Display Conditions with a missing value. They will all need to be fixed to resolve the issue
  • The error message will trigger when you try and open the topic containing the Display Condition with the missing value e.g. you may have a Menu Topic in your course with buttons to each of the other topics. When you click on the button for ‘Content Topic 1’ the error triggers. 
  • Once you’ve identified the topic that is triggering the error you will need to search through the Display Conditions for the screens/assets within the topic to see which ones are missing an asset ID value. The following are examples of where each type of Display Condition can be found; 

Screen level Display Condition

Asset Display Condition

  • Once you’ve identified the Display Condition with the missing value you will need to either remove the Display Condition or link it to an asset which still exists in the course. 
  • The error message should then be removed when you save and Preview the course again.